System Center Operations Manager by Jonathan Hambrook

May 10, 2007

SCOM Agents fail to install – Error: 80070643 and agentinstall.log error of 0x80070422

Filed under: Errors, Microsoft, SCOM 2007 — opsmgr @ 8:53 pm

You get a display error of 80070643

The problem is caused by a bug during the install, with the MSI custom action when it tries to register the agent for receiving updates via Microsoft Update. If the Windows Update/Automatic Update service is disabled install will fail.
This issue is bugged with Microsoft  and will be fixed in the future so that the setup will detect this situation and ignore the failure and continue with the install. Unfortunately the only option at this point as a workaround will be to enable Windows Update/Automatic Update on the machine for the purpose of the install.

Bellow is the extracts from the agentinstall.log and momagentmgmt.log

agentinstall.log
MSI (s) (D0:C4) [00:46:55:547]: Invoking remote custom action. DLL:
C:\WINDOWS\Installer\MSI150D.tmp, Entrypoint: CanRegisterMU
Action start 0:46:55: _CanRegisterMU.80B659D9_F758_4E7D_B4FA_E53FC737DCC9.
CanRegisterMU: WU version is greater than 5.8.0.2469so we can proceed further.
CanRegisterMU: get_Services() failed. Error Code: 0x80070422.
MSI (s) (D0:98) [00:46:55:829]: Machine policy value ‘DisableRollback’ is 0
MSI (s) (D0:98) [00:46:55:829]: Note: 1: 1402 2:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 Action ended 0:46:55: _CanRegisterMU.80B659D9_F758_4E7D_B4FA_E53FC737DCC9.
Return value 3.
MSI (s) (D0:98) [00:46:55:829]: Note: 1: 1402 2:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (D0:98) [00:46:55:829]: No System Restore sequence number for this installation.
MSI (s) (D0:98) [00:46:55:829]: Unlocking ServerAction ended 0:46:55: INSTALL. Return value 3.

momagentmgmt.log
12:46:42 AM : CServiceModule::SetServiceStatus : State: 4, Error: 0
12:46:43 AM : CMOMAgentFunctions::GetPatches : Entering
12:46:43 AM : CMOMAgentFunctions::GetPatches : MsiGetProductCode failed HResult: 80070647 

Advertisements

1 Comment »

  1. hi,
    i was facing the same error and i tried with the steps suggested. but it’s not helping. is there any other way to resolve this problem?

    Comment by Smeeta — October 3, 2007 @ 3:41 pm


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: