System Center Operations Manager by Jonathan Hambrook

June 28, 2007

Custom created Management Pack with custom rules don’t show correctly in Reporting

Filed under: Issues, Microsoft, SCOM 2007 — opsmgr @ 8:59 pm

I have found the following Issue when creating a report from a Custom Performance Counter that was added to a Custom Management Pack.

If you would like to follow along, First, create a new Management Pack and then under Authoring create a Rule for a performance counter ie: % Processor Time.

Second, go to Reporting and under “Microsoft Generic Report Library” open the “Performance” report and fill out all the details. When you go to selecting the counter you will see an uninterperatable name. This is displayed as a sequence of numbers and letters where the counter name should be, this is obvious from the screenshot below:

Rule Name Not Showing correctly in SCOM Reporting

This becomes a real neusence when you get your report results as the ‘Rule:’ detail is not interperatable. So should you forget what you printed or saved, you will not be able to reference this in the feature. See the follow screenshot:

Performance Rule Unreadable Rule Name

I have highlighted where you should see what the counter name is, if you were to look back at this report in the future you would not be able to tell that it was % Processor Time.

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.

%d bloggers like this: